THIS IS A TEST INSTANCE ONLY! REPOSITORIES CAN BE DELETED AT ANY TIME!

Browse Source

Use vendors when go generate (#7340)

* use vendors when go generate

* update docs about golang minimal requirement from 1.9 to 1.11

* fix build
master
Lunny Xiao techknowlogick 4 months ago
parent
commit
87404d7c0b
4 changed files with 7 additions and 5 deletions
  1. +4
    -2
      .drone.yml
  2. +1
    -1
      Makefile
  3. +1
    -1
      docs/content/doc/advanced/hacking-on-gitea.en-us.md
  4. +1
    -1
      docs/content/doc/installation/from-source.en-us.md

+ 4
- 2
.drone.yml View File

@@ -63,9 +63,11 @@ steps:

- name: build-without-gcc
pull: always
image: golang:1.10 # this step is kept as the lowest version of golang that we support
image: golang:1.11 # this step is kept as the lowest version of golang that we support
environment:
GO111MODULE: on
commands:
- go build -o gitea_no_gcc # test if build succeeds without the sqlite tag
- go build -mod=vendor -o gitea_no_gcc # test if build succeeds without the sqlite tag

- name: build
pull: always


+ 1
- 1
Makefile View File

@@ -97,7 +97,7 @@ vet:

.PHONY: generate
generate:
GO111MODULE=on $(GO) generate $(PACKAGES)
GO111MODULE=on $(GO) generate -mod=vendor $(PACKAGES)

.PHONY: generate-swagger
generate-swagger:


+ 1
- 1
docs/content/doc/advanced/hacking-on-gitea.en-us.md View File

@@ -32,7 +32,7 @@ necessary. To be able to use these you must have the `"$GOPATH"/bin` directory
on the executable path. If you don't add the go bin directory to the
executable path you will have to manage this yourself.

**Note 2**: Go version 1.9 or higher is required; however, it is important
**Note 2**: Go version 1.11 or higher is required; however, it is important
to note that our continuous integration will check that the formatting of the
source code is not changed by `gofmt` using `make fmt-check`. Unfortunately,
the results of `gofmt` can differ by the version of `go`. It is therefore


+ 1
- 1
docs/content/doc/installation/from-source.en-us.md View File

@@ -27,7 +27,7 @@ necessary. To be able to use these, you must have the `"$GOPATH/bin"` directory
on the executable path. If you don't add the go bin directory to the
executable path, you will have to manage this yourself.

**Note 2**: Go version 1.9 or higher is required. However, it is recommended to
**Note 2**: Go version 1.11 or higher is required. However, it is recommended to
obtain the same version as our continuous integration, see the advice given in
<a href='{{< relref "doc/advanced/hacking-on-gitea.en-us.md" >}}'>Hacking on
Gitea</a>


Loading…
Cancel
Save